import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*\\[(?P<id>\\d+)\\]\\s*:\\s*(?P<link>[^\\n]+)$";
final String string = "This is a sample doucument that would have inline links. \n"
+ "[Example 0][0], [Example 1][1], [Example 2][2] , [Example 3][3] , [Example 4][4]\n\n"
+ "[0]: http://example.com\n"
+ " [1]: http://example.com/1\n"
+ " [2] : http://example.com/2\n"
+ " [3]: http://example.com/3\n"
+ " [4] : http://example.com/4";
final String subst = "[\\1]: \\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}