package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*\[(?P<id>\d+)\]\s*:\s*(?P<link>[^\n]+)$`)
var str = `This is a sample doucument that would have inline links.
[Example 0][0], [Example 1][1], [Example 2][2] , [Example 3][3] , [Example 4][4]
[0]: http://example.com
[1]: http://example.com/1
[2] : http://example.com/2
[3]: http://example.com/3
[4] : http://example.com/4`
var substitution = "[\1]: \2"
fmt.Println(re.ReplaceAllString(str, substitution))
}