use strict;
my $str = 'This is a sample doucument that would have inline links.
[Example 0][0], [Example 1][1], [Example 2][2] , [Example 3][3] , [Example 4][4]
[0]: http://example.com
[1]: http://example.com/1
[2] : http://example.com/2
[3]: http://example.com/3
[4] : http://example.com/4';
my $regex = qr/^\s*\[(?P<id>\d+)\]\s*:\s*(?P<link>[^\n]+)$/mp;
my $subst = '[\\1]: \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";