const regex = /^\s*\[(?P<id>\d+)\]\s*:\s*(?P<link>[^\n]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*\\[(?P<id>\\d+)\\]\\s*:\\s*(?P<link>[^\\n]+)$', 'gm')
const str = `This is a sample doucument that would have inline links.
[Example 0][0], [Example 1][1], [Example 2][2] , [Example 3][3] , [Example 4][4]
[0]: http://example.com
[1]: http://example.com/1
[2] : http://example.com/2
[3]: http://example.com/3
[4] : http://example.com/4`;
const subst = `[\1]: \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);