$re = '/^\s*\[(?P<id>\d+)\]\s*:\s*(?P<link>[^\n]+)$/m';
$str = 'This is a sample doucument that would have inline links.
[Example 0][0], [Example 1][1], [Example 2][2] , [Example 3][3] , [Example 4][4]
[0]: http://example.com
[1]: http://example.com/1
[2] : http://example.com/2
[3]: http://example.com/3
[4] : http://example.com/4';
$subst = "[\1]: \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;