#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(<td(?=.*?class="MID")[^>]*>(?:(?!<\/td>).)*<\/td>)"
Local $sString = "<td width="33%" align="left" class="MID">" & @CRLF & _
" <a href="ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA">IOWA</a>" & @CRLF & _
" </td>" & @CRLF & _
"<td width="33%" align="left">" & @CRLF & _
" <a href="ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA">IOWA</a>" & @CRLF & _
" </td>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")