const regex = /(<td(?=.*?class="MID")[^>]*>(?:(?!<\/td>).)*<\/td>)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<td(?=.*?class="MID")[^>]*>(?:(?!<\\\/td>).)*<\\\/td>)', 'gs')
const str = `<td width="33%" align="left" class="MID">
<a href="ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA">IOWA</a>
</td>
<td width="33%" align="left">
<a href="ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA">IOWA</a>
</td>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}