using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<td(?=.*?class=""MID"")[^>]*>(?:(?!<\/td>).)*<\/td>)";
string input = @"<td width=""33%"" align=""left"" class=""MID"">
<a href=""ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA"">IOWA</a>
</td>
<td width=""33%"" align=""left"">
<a href=""ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA"">IOWA</a>
</td>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}