$re = '/(<td(?=.*?class="MID")[^>]*>(?:(?!<\/td>).)*<\/td>)/s';
$str = '<td width="33%" align="left" class="MID">
<a href="ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA">IOWA</a>
</td>
<td width="33%" align="left">
<a href="ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA">IOWA</a>
</td>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);