using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([a-z][a-z0-9]*)(?:[^>]*(\s(src|href|style)=['\""][^'\""]*['\""]))?[^>]*?(\/?)>";
string substitution = @"<$1$2$4>";
string input = @"<title>Hello World</title>
<div fadeout""="" style=""margin:0px;"" class=""xyz"">
<img src=""abc.jpg"" alt="" />
<p style=""margin-bottom:10px;"">The event is celebrating its 50th anniversary Kö <a style=""margin:0px;"" href=""http://www.germany.travel/"">exhibition grounds in Cologne</a>.</p>
<p style=""padding:0px;""></p>
<p style=""color:black;""><strong>A festival for art lovers</strong></p>
</div>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}