# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<([a-z][a-z0-9]*)(?:[^>]*(\s(src|href|style)=['\"][^'\"]*['\"]))?[^>]*?(\/?)>"
test_str = ("<title>Hello World</title>\n"
"<div fadeout\"=\"\" style=\"margin:0px;\" class=\"xyz\">\n"
"<img src=\"abc.jpg\" alt=\"\" />\n"
"<p style=\"margin-bottom:10px;\">The event is celebrating its 50th anniversary Kö <a style=\"margin:0px;\" href=\"http://www.germany.travel/\">exhibition grounds in Cologne</a>.</p>\n"
"<p style=\"padding:0px;\"></p>\n"
"<p style=\"color:black;\"><strong>A festival for art lovers</strong></p>\n"
"</div>")
subst = "<$1$2$4>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.