// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<([a-z][a-z0-9]*)(?:[^>]*(\s(src|href|style)=['\"][^'\"]*['\"]))?[^>]*?(\/?)>"#).unwrap();
let string = "<title>Hello World</title>
<div fadeout\"=\"\" style=\"margin:0px;\" class=\"xyz\">
<img src=\"abc.jpg\" alt=\"\" />
<p style=\"margin-bottom:10px;\">The event is celebrating its 50th anniversary Kö <a style=\"margin:0px;\" href=\"http://www.germany.travel/\">exhibition grounds in Cologne</a>.</p>
<p style=\"padding:0px;\"></p>
<p style=\"color:black;\"><strong>A festival for art lovers</strong></p>
</div>";
let substitution = "<$1$2$4>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}