re = /<([a-z][a-z0-9]*)(?:[^>]*(\s(src|href|style)=['\"][^'\"]*['\"]))?[^>]*?(\/?)>/
str = '<title>Hello World</title>
<div fadeout"="" style="margin:0px;" class="xyz">
<img src="abc.jpg" alt="" />
<p style="margin-bottom:10px;">The event is celebrating its 50th anniversary Kö <a style="margin:0px;" href="http://www.germany.travel/">exhibition grounds in Cologne</a>.</p>
<p style="padding:0px;"></p>
<p style="color:black;"><strong>A festival for art lovers</strong></p>
</div>'
subst = '<$1$2$4>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result