#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(£|\€|GBP)\s*?([0-9,]*)?\s*(\x28pro-rata\x29|pro-rata)"
Local $sString = ""Relevant Quantity Surveying construction drawings Salary: £36,999 (pro-rata) in accordance with standard construction terms ..."" & @CRLF & _
"" & @CRLF & _
""Relevant Quantity Surveying construction drawings Salary: £36,999 pro-rata in accordance with standard construction terms ...""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")