import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(£|\\€|GBP)\\s*?([0-9,]*)?\\s*(\\x28pro-rata\\x29|pro-rata)";
final String string = "\"Relevant Quantity Surveying construction drawings Salary: £36,999 (pro-rata) in accordance with standard construction terms ...\"\n\n"
+ "\"Relevant Quantity Surveying construction drawings Salary: £36,999 pro-rata in accordance with standard construction terms ...\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}