// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(£|\€|GBP)\s*?([0-9,]*)?\s*(\x28pro-rata\x29|pro-rata)").unwrap();
let string = "\"Relevant Quantity Surveying construction drawings Salary: £36,999 (pro-rata) in accordance with standard construction terms ...\"
\"Relevant Quantity Surveying construction drawings Salary: £36,999 pro-rata in accordance with standard construction terms ...\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}