re = /(£|\€|GBP)\s*?([0-9,]*)?\s*(\x28pro-rata\x29|pro-rata)/m
str = '"Relevant Quantity Surveying construction drawings Salary: £36,999 (pro-rata) in accordance with standard construction terms ..."
"Relevant Quantity Surveying construction drawings Salary: £36,999 pro-rata in accordance with standard construction terms ..."'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end