const regex = /(£|\€|GBP)\s*?([0-9,]*)?\s*(\x28pro-rata\x29|pro-rata)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(£|\\€|GBP)\\s*?([0-9,]*)?\\s*(\\x28pro-rata\\x29|pro-rata)', 'mg')
const str = `"Relevant Quantity Surveying construction drawings Salary: £36,999 (pro-rata) in accordance with standard construction terms ..."
"Relevant Quantity Surveying construction drawings Salary: £36,999 pro-rata in accordance with standard construction terms ..."`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}