using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(£|\€|GBP)\s*?([0-9,]*)?\s*(\x28pro-rata\x29|pro-rata)";
string input = @"""Relevant Quantity Surveying construction drawings Salary: £36,999 (pro-rata) in accordance with standard construction terms ...""
""Relevant Quantity Surveying construction drawings Salary: £36,999 pro-rata in accordance with standard construction terms ...""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}