#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?![[:alnum:]]|@|-|_|\.)."
Local $sString = "test109@email.com" & @CRLF & _
"teS%&/\()=? `t-109@em'ail.com" & @CRLF & _
"test_-abc0/!"§$%&/\()=? ` *ÜÄÖ'_:;,.-~1@emai.com" & @CRLF & _
"Test.info@email.com" & @CRLF & _
"test.in\fo@email-a/!"§$%&/\()=ddr.c *ÜÄÖ'_:;,.net" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")