use strict;
my $str = 'test109@email.com
teS%&/\\()=? `t-109@em\'ail.com
test_-abc0/!"§$%&/\\()=? ` *ÜÄÖ\'_:;,.-~1@emai.com
Test.info@email.com
test.in\\fo@email-a/!"§$%&/\\()=ddr.c *ÜÄÖ\'_:;,.net
';
my $regex = qr/(?![[:alnum:]]|@|-|_|\.)./p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}