import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?![[:alnum:]]|@|-|_|\\.).";
final String string = "test109@email.com\n"
+ "teS%&/\\()=? `t-109@em'ail.com\n"
+ "test_-abc0/!\"§$%&/\\()=? ` *ÜÄÖ'_:;,.-~1@emai.com\n"
+ "Test.info@email.com\n"
+ "test.in\\fo@email-a/!\"§$%&/\\()=ddr.c *ÜÄÖ'_:;,.net\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}