$re = '/(?![[:alnum:]]|@|-|_|\.)./';
$str = 'test109@email.com
teS%&/\\()=? `t-109@em\'ail.com
test_-abc0/!"§$%&/\\()=? ` *ÜÄÖ\'_:;,.-~1@emai.com
Test.info@email.com
test.in\\fo@email-a/!"§$%&/\\()=ddr.c *ÜÄÖ\'_:;,.net
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);