re = /(?![[:alnum:]]|@|-|_|\.)./
str = 'test109@email.com
teS%&/\\()=? `t-109@em\'ail.com
test_-abc0/!"§$%&/\\()=? ` *ÜÄÖ\'_:;,.-~1@emai.com
Test.info@email.com
test.in\\fo@email-a/!"§$%&/\\()=ddr.c *ÜÄÖ\'_:;,.net
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end