import Foundation
let pattern = #"(?![[:alnum:]]|@|-|_|\.)."#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
test109@email.com
teS%&/\()=? `t-109@em'ail.com
test_-abc0/!"§$%&/\()=? ` *ÜÄÖ'_:;,.-~1@emai.com
Test.info@email.com
test.in\fo@email-a/!"§$%&/\()=ddr.c *ÜÄÖ'_:;,.net
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)