# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[(quote)\]?\s*(?:author)?=?(\S+)*"
test_str = ("[quote author=username link=1150111054/0#7 date=1150151926][/quote]\n\n"
"[quote] username link=1142890417/0#43 date=1156429613]This is a very simple test sentence.[/quote]\n\n"
"[quote=user name pid=123456]\n"
"Test.[/quote]\n\n"
"[quote] user name link=1142890417/0#43 date=1156429613][quote] username link=1142890417/0#43 date=1156429613]This is a very simple test sentence.[/quote]\n"
"This is a very simple test sentence.[/quote]\n")
subst = "[$1=$2]"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.