// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[(quote)\]?\s*(?:author)?=?(\S+)*").unwrap();
let string = "[quote author=username link=1150111054/0#7 date=1150151926][/quote]
[quote] username link=1142890417/0#43 date=1156429613]This is a very simple test sentence.[/quote]
[quote=user name pid=123456]
Test.[/quote]
[quote] user name link=1142890417/0#43 date=1156429613][quote] username link=1142890417/0#43 date=1156429613]This is a very simple test sentence.[/quote]
This is a very simple test sentence.[/quote]
";
let substitution = "[$1=$2]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}