re = /\[(quote)\]?\s*(?:author)?=?(\S+)*/m
str = '[quote author=username link=1150111054/0#7 date=1150151926][/quote]
[quote] username link=1142890417/0#43 date=1156429613]This is a very simple test sentence.[/quote]
[quote=user name pid=123456]
Test.[/quote]
[quote] user name link=1142890417/0#43 date=1156429613][quote] username link=1142890417/0#43 date=1156429613]This is a very simple test sentence.[/quote]
This is a very simple test sentence.[/quote]
'
subst = '[$1=$2]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result