import Foundation
let pattern = #"\[(quote)\]?\s*(?:author)?=?(\S+)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
[quote author=username link=1150111054/0#7 date=1150151926][/quote]
[quote] username link=1142890417/0#43 date=1156429613]This is a very simple test sentence.[/quote]
[quote=user name pid=123456]
Test.[/quote]
[quote] user name link=1142890417/0#43 date=1156429613][quote] username link=1142890417/0#43 date=1156429613]This is a very simple test sentence.[/quote]
This is a very simple test sentence.[/quote]
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[$1=$2]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)