using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(0123456789|012345678|01234567|0123456|012345|01234|0123|012|01|0)+";
string input = @"0ll0136544456660000012345602012345678901234567890123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}