const regex = /(0123456789|012345678|01234567|0123456|012345|01234|0123|012|01|0)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(0123456789|012345678|01234567|0123456|012345|01234|0123|012|01|0)+', 'gm')
const str = `0ll0136544456660000012345602012345678901234567890123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}