import re
regex = re.compile(r"(0123456789|012345678|01234567|0123456|012345|01234|0123|012|01|0)+", flags=re.MULTILINE)
test_str = "0ll0136544456660000012345602012345678901234567890123"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")