$re = '/(0123456789|012345678|01234567|0123456|012345|01234|0123|012|01|0)+/m';
$str = '0ll0136544456660000012345602012345678901234567890123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);