package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(0123456789|012345678|01234567|0123456|012345|01234|0123|012|01|0)+`)
var str = `0ll0136544456660000012345602012345678901234567890123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}