// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(0123456789|012345678|01234567|0123456|012345|01234|0123|012|01|0)+").unwrap();
let string = "0ll0136544456660000012345602012345678901234567890123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}