#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:<del>|<b>)?(?<planned>[^<>]*)(?:<\/del>|<\/b>)?(?:<b> \+(?<actual>[^<>]+)<\/b>)? ?(?:\((?<note>[^\(\)]+)\))?$"
Local $sString = "<del>C 1.14</del><b> + C 1.15</b> (gesperrt:Raum nicht verfügbar)" & @CRLF & _
"<del>KIT</del><b> +BOL</b>" & @CRLF & _
"<del>KIT</del> (Arbeitsauftrag als Hausaufgabe)" & @CRLF & _
"FRJ" & @CRLF & _
"<b> WOK</b>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")