const regex = /^(?:<del>|<b>)?(?<planned>[^<>]*)(?:<\/del>|<\/b>)?(?:<b> \+(?<actual>[^<>]+)<\/b>)? ?(?:\((?<note>[^\(\)]+)\))?$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:<del>|<b>)?(?<planned>[^<>]*)(?:<\\\/del>|<\\\/b>)?(?:<b> \\+(?<actual>[^<>]+)<\\\/b>)? ?(?:\\((?<note>[^\\(\\)]+)\\))?$', 'mg')
const str = `<del>C 1.14</del><b> + C 1.15</b> (gesperrt:Raum nicht verfügbar)
<del>KIT</del><b> +BOL</b>
<del>KIT</del> (Arbeitsauftrag als Hausaufgabe)
FRJ
<b> WOK</b>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}