$re = '/^(?:<del>|<b>)?(?<planned>[^<>]*)(?:<\/del>|<\/b>)?(?:<b> \+(?<actual>[^<>]+)<\/b>)? ?(?:\((?<note>[^\(\)]+)\))?$/m';
$str = '<del>C 1.14</del><b> + C 1.15</b> (gesperrt:Raum nicht verfügbar)
<del>KIT</del><b> +BOL</b>
<del>KIT</del> (Arbeitsauftrag als Hausaufgabe)
FRJ
<b> WOK</b>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);