re = /^(?:<del>|<b>)?(?<planned>[^<>]*)(?:<\/del>|<\/b>)?(?:<b> \+(?<actual>[^<>]+)<\/b>)? ?(?:\((?<note>[^\(\)]+)\))?$/m
str = '<del>C 1.14</del><b> + C 1.15</b> (gesperrt:Raum nicht verfügbar)
<del>KIT</del><b> +BOL</b>
<del>KIT</del> (Arbeitsauftrag als Hausaufgabe)
FRJ
<b> WOK</b>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end