using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:<del>|<b>)?(?<planned>[^<>]*)(?:<\/del>|<\/b>)?(?:<b> \+(?<actual>[^<>]+)<\/b>)? ?(?:\((?<note>[^\(\)]+)\))?$";
string input = @"<del>C 1.14</del><b> + C 1.15</b> (gesperrt:Raum nicht verfügbar)
<del>KIT</del><b> +BOL</b>
<del>KIT</del> (Arbeitsauftrag als Hausaufgabe)
FRJ
<b> WOK</b>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}