use strict;
my $str = '<del>C 1.14</del><b> + C 1.15</b> (gesperrt:Raum nicht verfügbar)
<del>KIT</del><b> +BOL</b>
<del>KIT</del> (Arbeitsauftrag als Hausaufgabe)
FRJ
<b> WOK</b>';
my $regex = qr/^(?:<del>|<b>)?(?<planned>[^<>]*)(?:<\/del>|<\/b>)?(?:<b> \+(?<actual>[^<>]+)<\/b>)? ?(?:\((?<note>[^\(\)]+)\))?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}