#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\s\d!@£$%^&*()+=]*$"
Local $sString = "123" & @CRLF & _
"" & @CRLF & _
"jl" & @CRLF & _
"" & @CRLF & _
"sdf$fd" & @CRLF & _
"" & @CRLF & _
"fds fdsfds" & @CRLF & _
"23 123" & @CRLF & _
"" & @CRLF & _
"James1" & @CRLF & _
"" & @CRLF & _
"James" & @CRLF & _
"" & @CRLF & _
"James Rose"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")