re = /^[^\s\d!@£$%^&*()+=]*$/m
str = '123
jl
sdf$fd
fds fdsfds
23 123
James1
James
James Rose'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end