#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)\\\\[^. ]*\K|(?!^)\G\.([^. ]*)"
Local $sString = "A.B.C.\\valid.A .\\valid.A.B.C .\\valid.X.Y.Z .p.q.r.s "
Local $sSubst = "?$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)