import Foundation
let pattern = #"\\\\[^. ]*\K|(?!^)\G\.([^. ]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"A.B.C.\\valid.A .\\valid.A.B.C .\\valid.X.Y.Z .p.q.r.s "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"?$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)