const regex = /\\\\[^. ]*\K|(?!^)\G\.([^. ]*)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\\\\\[^. ]*\\K|(?!^)\\G\\.([^. ]*)', 'gi')
const str = `A.B.C.\\\\valid.A .\\\\valid.A.B.C .\\\\valid.X.Y.Z .p.q.r.s `;
const subst = `?$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);