use strict;
my $str = 'A.B.C.\\\\valid.A .\\\\valid.A.B.C .\\\\valid.X.Y.Z .p.q.r.s ';
my $regex = qr/\\\\[^. ]*\K|(?!^)\G\.([^. ]*)/ip;
my $subst = '?$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";