$re = '/\\\\\\\\[^. ]*\K|(?!^)\G\.([^. ]*)/i';
$str = 'A.B.C.\\\\valid.A .\\\\valid.A.B.C .\\\\valid.X.Y.Z .p.q.r.s ';
$subst = "?$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;