using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\\\[^. ]*\K|(?!^)\G\.([^. ]*)";
string substitution = @"?$1";
string input = @"A.B.C.\\valid.A .\\valid.A.B.C .\\valid.X.Y.Z .p.q.r.s ";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}