#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^.*?(\bEventname 2\b).*$"
Local $sString = "<select id="filter_event_id" name="filter_event_id" class="inputbox chzn-done" onchange="submit();" style="display: none;">" & @CRLF & _
" <option value="0">Select Event</option>" & @CRLF & _
" <option value="113">Eventname (RB113) (02-05-2015)</option>" & @CRLF & _
" <option value="104">Eventname 2 (T104) (09-05-2015)</option>" & @CRLF & _
" <option value="109">Eventname 3 (M109) (15-05-2015)</option>" & @CRLF & _
" <option value="99" selected="selected">Eventname 4 (M99) (24-04-2015)</option>" & @CRLF & _
"</select>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")